imooc 《强力Django+杀手级Xadmin打造在线教育平台》踩坑记录

释放双眼,带上耳机,听听看~!

参数说明:
Django1.11
mysql5.6
Windows7: python3.6, pycharm社区版
ubuntu14.04: python3.4, pycharm专业版

坑1:Django 1.11的 “migrate” 出现”InconsistentMigrationHistory”报错

课程4-4“自定义userprofile”中出现,老师编写完自定义的user model 后对数据库做 makemigrationsmigrate 操作。然而我在 migrate 的时候却出现了如下错误

>>>python manage.py migrate
System check identified some issues:

WARNINGS:
?: (mysql.W002) MySQL Strict Mode is not set for database connection 'default'

......

django.db.migrations.exceptions.InconsistentMigrationHistory: Migration admin.00
01_initial is applied before its dependency users.0001_initial on database 'defa
ult'.


这种情况出现的原因是django版本的差异引起的,老师使用的是django1.9,而Django1.10后添加了一个新特性,就是在migrate的时候会检查历史一致性,就像github在push前会检查新旧版本之间是否有冲突
imooc 《强力Django+杀手级Xadmin打造在线教育平台》踩坑记录

我的做法很粗暴,直接把原数据库所有表清空(删除数据库再新建数据库), 再把users目录的migrations目录下的0001_initial.py删掉,重新执行

>>>python manage.py makemigrations
>>>python manage.py migrate

imooc 《强力Django+杀手级Xadmin打造在线教育平台》踩坑记录

imooc 《强力Django+杀手级Xadmin打造在线教育平台》踩坑记录
总觉得这种做法不够优雅,有更好的方法的同学欢迎贴在评论区分享出来

坑2:Ubuntu14.04下安装mysqlclient出错

Ubuntu下安装·mysqlclient·(python3的MySQL驱动)时会出现安装失败的情况
imooc 《强力Django+杀手级Xadmin打造在线教育平台》踩坑记录
解:
Ubuntu下的 mysqlclient 依赖 libmysqlclient-dev,所以要先安装这个库

sudo apt-get install libmysqlclient-dev
sudo pip3 install mysqlclient

然后就成功安装了。

坑3:python3.4 xadmin报错

在ubuntu14.04下使用xadmin时,无论是pip按照还是源码安装,在运行时都会出现一个ImportError
ImportError: No module named 'operationxadmin'
解:几经周折,还是找了老师在github上的xadmin版本用源码安装
https://github.com/liyaopinner/mxonline_resources
xadminDjandoUeditor 装到 extra_apps 后,就正常使用了
怀疑是xadmin对python3.4不支持


持续更新中······

【转自慕课】https://www.imooc.com

Python

python强势来袭-0014-函数中的那些变量

2022-3-3 10:42:11

Python

Django项目上线笔记(18.1.1)

2022-3-3 10:47:13

搜索